Deze plugin heb ik niet meer in gebruik, soms vanwege verouderd zijn, soms omdat ik een betere vond, soms omdat ik de functionaliteit niet meer nodig had en ook wel omdat ik er niet goed uitkwam

Exec php: niet meer onderhouden en levert problemen

Mooie kleine plugin, die ervoor zorgt dat php code in een widget wordt uitgevoerd:

  • Executes PHP code in the excerpt and the content portion of your posts and pages
  • Configurable execution of PHP code in text widgets (for WordPress 2.2 or higher)

https://wordpress.org/support/plugin/exec-php

Maar helaas: ontdekt dat hierdoor een editor niet meer de edit rechten heeft..

Het is soms lang zoeken, maar dit was de boosdoener.

 

HiermeeĀ bereik je het zelfde effect!

http://www.carriedils.com/extend-wordpress-widgets-without-plugin/

Plaats dit in je functions.php

  // Enable shortcodes in widgets  add_filter('widget_text', 'do_shortcode');  // Enable PHP in widgets  add_filter('widget_text','execute_php',100);  function execute_php($html){       if(strpos($html,"<"."?php")!==false){            ob_start();            eval("?".">".$html);            $html=ob_get_contents();            ob_end_clean();       }       return $html;  }